トップ «前の日記(2011/05/02(Mon)) 最新 次の日記(2011/05/11(Wed))» 編集
【ソース+水=麦茶色の何か】

半期 四半期 全カテゴリ

今日の一言


2011/05/08(Sun) 大帝国1週目クリア。同盟拒否で全領土制圧。ぴったり50ターン。 [長年日記]

_ [Ubuntu][FC][Debian][Linux][Windows][雑記] NEC製Lavie LL750/RでUSBブートを有効にする方法

単純に、「USB HDD」の優先度を上げるだけではUSBから起動してくれない。

優先度の変更に加え、BIOS画面で、「UBSレガシーサポート」を「Enable」にする必要がある。

・・・なぜ、こんな罠を?

_ [Windows][Ubuntu][FC][Debian][Linux][雑記]VMWare Playerで簡易インストールを『使わない』でOSをインストールする

新規でVMWare PlayerにUbuntu等をインストールしようとすると、自動的に簡易インストーラが選択されてしまう。

これは確かに便利なのだが、通常とは異なるインストール手順のため、細かな設定ができず、少し変わったインストールをしようとすると、とたんに面倒になる。

そこで、簡易インストールを使わないでこれらをOSをインストールする方法を説明する。

※VMWare Player上でLive CDとして起動させたい場合も、この方法を使えば可能。まあ、あまり需要は無いかも知れないが。

まずは通常と同様、VMWarePlayerを起動して「ファイル」から「新規仮想マシンの作成」を選択。

そして、3番目の『後でOSをインストール』を選択。

次に、OS選択画面があるので、「Linux」を選び、仮想マシン名、格納場所、ディスク容量等を設定。

最後に、「ハードウェアをカスタマイズ」をクリックし、新規CD/DVDが、「自動検出」、「起動時に接続」になっている事を確認。

なっていたら、OKを押して終了。

続いて、「仮想マシン」から「仮想マシンの設定」を開き、「CD/DVD」を、インストールしたいOSのisoファイルを読み込むように変更する。

これで、起動時に通常のインストーラが立ち上がるので、自分の好みに合わせてインストールする。

以上!

_ [Windows][Ubuntu][FC][Debian][Linux][雑記] VMWare PlayerでUbuntu11.04の新UI「Unity」を試す(ただし2D)

参考:

http://macosx.seesaa.net/article/199077168.html

「Ubuntu 11.04」では、デフォルトのデスクトップインターフェイスとしてCanonicalによる「Unity」シェルが採用されており、見た目もかなり変更されている。

しかし、VMware PlayerではOpenGL等の3Dグラフィックスがサポートされていないため、せっかく11.04をインストールしても、仮想マシン上で「Unity 3D」は適用できず、従来からのインターフェイス(Ubuntu Classic)が適用されてしまう。

ただ、まったく体験できないかというとそんなことはなく、2D環境で「Unityシェル」を体験できる「Unity 2D」というものが用意されている。

インストール方法は、端末から

$ sudo apt-get install unity-2d

と打つか、synapticを使えばOK。

良いものかどうかは・・・自分で確認してください。

_ [未まとめ]googleウェブ検索を自分好みにカスタマイズしてHPに貼り付ける

ここ(http://code.google.com/intl/ja/apis/customsearch/)を参考にすればOK?

というか、google code(http://code.google.com/intl/ja/)って、いろいろと興味をひかれるものが多いな。時間無いけど。

_ [Ubuntu][FC][Debian][Linux][Windows][雑記] Ubuntu11.04のフォルダやバーの概観がおかしくなる(テーマがうまく適用されないというか、なんかしょぼい)

バグ?

説明しにくいが、テーマを変更したときに変わる場所(バーやエクスプローラ、ボタンなど)の見た目が、やけにしょぼい。

具体的には、こんな感じ。

なんか見た目がしょぼい

VMWare Player3.1.4で動かした場合に生じたので、Ubuntuのバグなのか、VMWare Playerが対応していないからなのかは不明。

VMWarePlayerおよびVMWareToolsのアップデート、「apt-get update」後の「apt-get upgrade」や、ドライバの無効化・有効化をして再起動した結果、一度だけ、うまく動いた。

が、再度起動させたときにはまたこれに戻っていた。

というよりは、時間がたつとおかしくなってるのか?

・・・なんだこれ?

類似の事例を発見

どうも、以下の記事と同じ状況っぽい。

http://d.hatena.ne.jp/speg03/20110430/1304163602

ということは、VMWareのせいではなさそうだ。

ただ、自分はキーマップ変更して無いから、「./Xmodmap」ないんだよなぁ・・・。

とりあえず解決

以下のサイトを参考にさせていただきました。

http://www.transitive.info/2011/04/30/install-ubuntu-1104/

孫引きしてこちらも確認。

http://ubuntuforums.org/showpost.php?p=10739786&postcount=14
https://bugs.launchpad.net/ubuntu/+source/gnome-panel/+bug/773472

やはりバグか。

解決方法は、端末から

sudo gnome-settings-daemon

を実行する。

.Xmodmap を使用している場合は、さらに

xmodmap ~/.Xmodmap

も実行する。

よし、対処療法としてはこんなもんだろう。

あとはバグが修正されるのを待つか。

[]